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 ABOUT THIS GUIDE

Copyright
No part of this document may be reproduced or transmitted in any form or by 

any means, electronic or mechanical, including photocopying and recording, 

for any purpose without the express written consent of SilhouetteFX, LLC.

Copyright © SilhouetteFX, LLC 2018. All Rights Reserved

November 20, 2018

About Us
SilhouetteFX brings together the unbeatable combination of superior software 

designers and visual effects veterans. Add an Academy Award for Scientific 

and Technical Achievement, 3 Emmy Awards and experience in creating visual 

effects for hundreds of feature films, commercials and television shows and you 

have a recipe for success.
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 WHAT’S NEW IN 7.0 - 7/23/18

Features

Sequence Editor
Silhouette can perform editing tasks such as cutting, joining, moving, copying, 

replacing, trimming, retiming and repeating clips in the Sequence Editor.

Planar Tracker
The Silhouette Planar Tracker has undergone a major upgrade.

Previously only detecting features based on corners, the Planar Tracker can 

now track edges and ridges resulting in excellent results even with textureless 

objects. To achieve the best tracking result, you can choose between Auto, 

Corners, Edges or Ridges tracking feature modes as well as Perspective, 
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Affine and Translation motion models. Partial occlusions are handled, in most 

cases, without the need for subtract shapes while Drift Compensation 

algorithms are implemented to reduce tracker drift and to fine tune the result.

Roto
Combine Shapes
Copies selected points from a source shape between the selected points of a 

target shape.

Extract Shape
Extracts the selected points of a shape into a new closed shape.

Extrapolate Shapes
Shape start and end keyframes can now use Timeline extrapolation. This 

removes the need to add an extra keyframe on both sides to account for motion 

blur.

Reshape - Magnetic Mode (RR)
Points near the cursor move more than points farther away.
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Paint
Clone Brush Transform On-Screen Controls
The Paint > Clone brush transform on-screen controls were re-written so that 

they are now always visible regardless of zoom level. All transform controls are 

always available including corner-pin, rotation, scale, translation as well as the 

newly added skew controls.

Clone > Warp
The Clone > Warp allows you to warp specific image areas using pins, while 

leaving other areas untouched. Adjustments can range from subtle nip and 

tucks to something more obvious like repositioning an arm or leg.

Cutout Brush
Cuts out a portion of the image based on a rectangular selection, taking into 

account alpha if it exists, and paints using the cutout.

Stabilization
Previously, stabilization was limited to the active layer. Now, when the Stabilize 

icon is clicked, a list of all available nodes/layers are available to choose from. 

Once a layer is selected, stabilization is performed by the Viewer based on the 

selected layer’s tracking data.

Trees Window > Node Grouping
Nodes in the Trees window can be grouped, collapsed or expanded.
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Smooth (Catmull-Rom) Interpolation
Smooth (Catmull-Rom) interpolation creates a smooth animation curve 

between keyframes. Shapes using Smooth (Catmull-Rom) interpolation in 

Silhouette exactly match the result in Nuke when exported.

PySide Integration
Silhouette now includes PySide2 integration for the creation of custom docks, 

widgets, and dialogs.

Tracker > Smooth
Previously, only point trackers could be smoothed to remove jitter. Now, both 

point trackers and planar tracked layers can be smoothed using the Smooth 

button located below Pre-Processing.

New Nodes
The following new nodes were added.

Frost
A Frost filter was added to the Diffusion node group. Frost glows highlights and 

reduces contrast while softening facial blemishes and wrinkles.

Before After

Photo by Alexandru Zdrobau on Unsplash
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Lens Flare
A Lens Flare filter was added to the Light node group. Lens flares are produced 

by the scattering or flaring of light within a lens when pointed into a bright light. 

Although an image aberration, lens flares can be added for dramatic effect and 

are created by combining the following elements: Caustic, Chroma Bands, 

Chroma Ring, Circle, Circles, Disc, Edge Streak, Ellipse, Fan Rays, Hot Spot, 

Polygon, Polygons, Radial Streaks, Random Spikes, Ring, Spikes, Spiral Rays, 

Star, Star Caustic, and Stripe. 331 optical lens flare presets are included along 

with a Flare Editor where you can create your own flares.
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Pin Warp
Pin Warp allows you to warp specific image areas using pins, while leaving 

other areas untouched. Adjustments can range from subtle nip and tucks to 

something more obvious like repositioning an arm or leg.

Source Clip In and Out Points
Each clip in the Sources window can have a different in and out point which are 

used when creating a new session or editing in the Sequence Editor. Double-

clicking on a clip in the Sources window loads it into the Viewer and Mark IN 

and Mark OUT icons appear.

Sources Window Icons
Import and New Sequence icons have been added to the Sources window. 

Also, the new Search field makes it easy to find clips or sequences.

Backup Chooser
File > Open Backup opens a browser that lists the available backups by date 

and time which can then be loaded.

Managing Media Paths
You can now virtualize media paths in order to improve asset sharing between 

users, asset management and render servers by specifying the file path with a 

SFX_MEDIA environment variable.This is accomplished through a default 

Before

Photo by Tim Easley on Unsplash

After
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SfxContentResolver that maps a “sfx” scheme to the SFX_MEDIA environment 

variable, and vice versa. When importing media that is nested under 

SFX_MEDIA, it will replace the beginning of the path with “sfx://”.

Preferences
Shape > Interpolation Engine
A Shape > Interpolation Engine preference was added with Temporal and 

Spatial (Nuke-compatible) choices that apply only to shapes. Temporal enables 

all interpolation types except for Smooth (Catmull-Rom) while Spatial (Nuke-

compatible) is limited to Smooth (Catmull-Rom), Hold and Extrapolate. This 

ensures that shapes using Smooth (Catmull-Rom) interpolation in Silhouette 

exactly match the result in Nuke when exported.

Changes

Halo Renamed to Mist
Diffusion > Halo was renamed to Mist.

Net and Silk > Temperature
The Temperature group in Diffusion > Net and Silk was replaced with the Color 

Correct group.

Paint Node
Clone 1-5 Inputs Renamed
The Paint node’s Clone 1-5 inputs were renamed to Input 1-5 since other 

brushes can also use inputs.

Default Settings
When a new Paint node is created, the settings are now at their default rather 

the previous Paint node's state.

Roto
Self-Overlapping Roto Shapes
Shapes that overlap themselves subtracted where they overlapped. Now, the 

overlapping area is added instead of being subtracted.
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Tagging Points
Tag is now a toggle and is either enabled or not. Untag was then removed from 

the Reshape pop-up menu

Stabilizing A Nested Layer
When a nested layer is selected for stabilization, the transforms of the parent 

layers are now combined with the current layer.

Transform
The Transform > Wrap Edges control was removed since the Transform node 

no longer clips its output.

Zoom Shortcut Keys
+ and = zoom in and - zooms out in the Viewer and Trees windows. The 

previous I and O shortcut keys for zooming are now used for marking the 

source clip in and out points.
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 WHAT’S NEW IN 7.0.2 - 7/25/18

Bug Fixes

Clone > Warp Crashed With A Pen/Tablet
Clone > Warp would cause a crash when using a pen and tablet.

Merge Views Did Not Display the Right View
The Merge Views node did not display the right view.

Pin Warp - Obey Matte Input Removed 
The Obey Matte input on Pin Warp was removed since adding tacks is a better 

method for limiting the warp effect.

 WHAT’S NEW IN 7.0.3 - 7/27/18

Bug Fix

Magnet Mode With Transformed Layer 
The wrong points would move when using Magnet Mode if the shape was in a 

transformed layer.

 WHAT’S NEW IN 7.0.4 - 7/27/18

Bug Fix

Source Window > Delete Clip Crash
Deleting a clip in the Source Window caused a crash.

 WHAT’S NEW IN 7.0.5 - 7/30/18

Bug Fix

Paint Change State Is Not Zero Error
With Interactive mode enabled in the Paint > Clone Brush, a “Paint change 

state is not zero” error could occur when changing the Clone source Frame 

parameter.
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 WHAT’S NEW IN 7.0.6 - 8/06/18

Features

Transform Matrix Extrapolation
Transform Matrix keyframes can now be extrapolated. This is useful for 

extending motion blur beyond the current frame on shapes when the majority 

of the motion is from the matrix and not the shape.

Bug Fixes

Grouping Crash
Replacing or deleting a node within a group would cause a crash. Now, only 

ungrouped nodes can be deleted or replaced.

Paint Crash With ROI
When the DOD (Domain of Definition) was larger than the ROI (Region of 

Interest), painting outside the image area would cause a crash.

Stereo Align Crash
Adjusting the Stereo Offset in the Stereo Align view would cause a crash.

Stereo Align Keyboard Shortcuts Did Not Work
The Stereo Align Keyboard shortcuts did not work.
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 WHAT’S NEW IN 7.0.7 - 8/10/18

Bug Fixes

Nuke Export of Planar Tracked Shapes in Nested Layers
Exporting shapes in nested, planar tracked layers did not work properly.

Transform and Reshape Tool State
If the Transform tool was set to Points mode and the Reshape tool to Magnet 

mode, clicking on either of the icons switched it to the default tool's mode. Now, 

the state of the tool is remembered.
Silhouette v7 What’s New    
• 
• 
•
•
•



   Si

14 What’s New in 7.0.8 - 8/28/18

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

 WHAT’S NEW IN 7.0.8 - 8/28/18

Features

Paint > Layer Transform
If a layer is active in the Paint > Object List, it now appears in the Paint > 

Transform pop-up menu.

Bug Fixes

Deleted Paint Strokes Reappear in Paint History
Strokes on frame 1 of the Paint History were not deleted when the project was 

saved and reloaded.

Frost > Paint Crash
If you hooked up a Paint node after a Frost node and then selected the Clone 

brush, Silhouette crashed.

Nodelocked License Tool in Windows 7
The nodelocked license tool did not work properly with some Windows 7 

machines.

Object List on Linux
The Object List on some Linux distributions did not display all of the columns.
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 WHAT’S NEW IN 7.0.9 - 11/20/18

Features

Paint On-Screen Controls Anchor Point
The Paint on-screen controls anchor point can now be set with the period key.

Roto Node > Antialiasing
Added an Antialiasing switch to the Roto node parameters. It is on by default.

Tracker > Create Point Trackers in Root > Preference
Added a Create Point Trackers in Root Preference. When enabled, point 

trackers are placed in the root of the Object list, rather than the selected layer.

Viewer Zoom Level Presets
Added 15%, 10% and 5% presets in the Viewer > Zoom pop-up menu. In 

addition, the scroll wheel will zoom the image down to 0%.

Changes

Window > Close and Maximize Icons Hard To See
The user interface window’s close and maximize icons were lightened and are 

now easier to see.

Nuke Export > Enable Global Motion Blur By Default
Global Motion Blur is now automatically enabled in Nuke for exported shapes. 

This results in a more faithful representation of motion blur between Silhouette 

and Nuke.

Source Thumbnails Now OCIO Color Managed
The source thumbnail images are now OCIO color managed.

Bug Fixes

Clone Source Pop-up Changed When Switching Nodes
Switching between nodes changed the selection in the Clone source pop-up 

menu.
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Grain > Blue Channel Did Not Animate
The Grain > Blue channel did not animate.

Motion Blur Artifacts With Multiple Roto Nodes
When you had multiple Roto nodes with Motion Blur enabled, the bottom node 

messed up the Motion Blur of the upstream node.

Nuke Exporter - B-Splines
The interpolation type for B-Splines was not exported to Nuke.

Nuke Exporter - Shapes Not In Layer
Shapes not in layer exported upside down.

OFX Memory Leak
Found and fixed an image memory leak in the OFX support.

Paint - Clone Brush Scale Values
The Clone brush scale values showed 0,0 initially.

Paint - Clone Rotation With Scaling Incorrect
When using Clone > Rotation in conjunction with Scaling, the painted result 

was incorrect.

Paint On-Screen Controls Anchor Point - QWE
Setting the on-screen controls anchor point with the Q,W, and E keys did not 

work.

Paint - Rebuild - Linux
On Linux, strokes drifted when using Paint > Rebuild.

Pen/Tablet - Cursor Did Not Update
When using a Pen/Tablet, the cursor did not update when changing views.

Pen/Tablet - Hovering
The Pen/Tablet did not trigger hover events on Linux.

Pen/Tablet - Lagging
The Pen/Tablet could lag under certain circumstances.
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Pen/Tablet - Won't Edit ROI in Mac/Linux
The tablet could not be used to edit the ROI on Mac/Linux.

Reversing Bezier Control Points and Feather Tangents
Reversing bezier control points did not reverse feather tangents.

Stereo Align With Non-Session Size DOD
The stereo alignment overlay did weird things when the image DOD did not 

match the session DOD.

Tracking Preview - Image Shift - Linux
When using the tracking preview, if you adjusted the contrast or gamma, the 

image moved approximately 2 pixels horizontally.
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